通过系统默认源安装的subversion最新版本是:1.8x,参见:jessie中subversion,可以通过本方法安装最新版subversion(当前版本是:1.9.7),内容如下:

1、获取WanDisco仓库

# download the GPG key of the repository and add it to apt:
wget http://opensource.wandisco.com/wandisco-debian.gpg -O /tmp/wandisco-debian.gpg
# add downloaded key to apt
apt-key add /tmp/wandisco-debian.gpg
# create apt sources file for wandisco repo
echo "deb http://opensource.wandisco.com/debian/ jessie svn19" > /etc/apt/sources.list.d/wandisco.sources.list

- 阅读剩余部分 -

Extjs Combo控件setValue() 显示ID或无效

针对ExtJS 3.x,不过其他版本原理一样
背景:在需要查看相关信息进行编辑form时,原来form表单中设置好的combo可能需要重新设置值,但在这之前需要加载显示原来的值。但是头疼的是,combo要么显示正常要么显示后台id。

- 阅读剩余部分 -

LNMP环境即:Linux+Nginx+MySQL+PHP

安装前准备

更新系统

apt-get update
apt-get dist-upgrade

说明:本操作是针对debian、ubuntu等Linux Distribution,程序安装用aptitude(也可以用apt-get替换,不过推荐用aptitude,这个程序是基于apt-get进行优化扩展,更易用。)

- 阅读剩余部分 -